Build: #36 failed Changes by Julian Christl

Build result summary

Details

Completed
Duration
12 seconds
Labels
None
Agent
Andromeda One
Revision
dfee83abba5ba66976871aa54fe6666e83b99bf7 dfee83abba5ba66976871aa54fe6666e83b99bf7
Failing since
#24 (Manual run by Daniel Gruber)
No failed test found. A possible compilation error occurred.

Responsible

This build has been failing since #24
No one has taken responsibility

Code commits

Author Commit Message Commit date
Julian Christl Julian Christl dfee83abba5ba66976871aa54fe6666e83b99bf7 dfee83abba5ba66976871aa54fe6666e83b99bf7 updated to php 7.1, fixed inheritance issue

Error summary for Default Job

The job generated some errors, drill down into the full build log for more details.

Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. It is recommended that you run `composer update` or `composer update <package name>`.
Nothing to install or update
Package phpunit/php-token-stream is abandoned, you should avoid using it. No replacement was suggested.
Generating autoload files
16 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - phpunit/phpunit 9.4.1 requires sebastian/version ^3.0.2 -> satisfiable by sebastian/version[3.0.2].
    - phpunit/phpunit 9.4.2 requires sebastian/version ^3.0.2 -> satisfiable by sebastian/version[3.0.2].
    - phpunit/phpunit 9.4.3 requires sebastian/version ^3.0.2 -> satisfiable by sebastian/version[3.0.2].
    - phpunit/phpunit 9.4.4 requires sebastian/version ^3.0.2 -> satisfiable by sebastian/version[3.0.2].
    - phpunit/phpunit 9.5.0 requires sebastian/version ^3.0.2 -> satisfiable by sebastian/version[3.0.2].
    - Conclusion: don't install sebastian/version 3.0.2
    - Installation request for sebastian/version (locked at 2.0.1) -> satisfiable by sebastian/version[2.0.1].
    - phpunit/phpunit 9.2.6 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.0 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.1 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.10 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.11 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.2 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.3 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.4 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.5 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.6 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.7 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.8 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.3.9 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - phpunit/phpunit 9.4.0 requires sebastian/version ^3.0.1 -> satisfiable by sebastian/version[3.0.1, 3.0.2].
    - Conclusion: don't install sebastian/version 3.0.1
    - phpunit/phpunit 9.0.0 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.0.1 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.0.2 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.1.0 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.1.1 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.1.2 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.1.3 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.1.4 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.1.5 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.2.0 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.2.1 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.2.2 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.2.3 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.2.4 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - phpunit/phpunit 9.2.5 requires sebastian/version ^3.0 -> satisfiable by sebastian/version[3.0.0, 3.0.1, 3.0.2].
    - Conclusion: don't install sebastian/version 3.0.0
    - Installation request for phpunit/phpunit ^9 -> satisfiable by phpunit/phpunit[9.0.0, 9.0.1, 9.0.2, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.1.4, 9.1.5, 9.2.0, 9.2.1, 9.2.2, 9.2.3, 9.2.4, 9.2.5, 9.2.6, 9.3.0, 9.3.1, 9.3.10, 9.3.11, 9.3.2, 9.3.3, 9.3.4, 9.3.5, 9.3.6, 9.3.7, 9.3.8, 9.3.9, 9.4.0, 9.4.1, 9.4.2, 9.4.3, 9.4.4, 9.5.0].


Installation failed, reverting ./composer.json to its original content.